The major browsers will be dropping support for TLS versions 1.0 and 1.1 in early 2020.  In order to keep our product in alignment with industry standard security protocols,  FinLocker will also be dropping support for TLS versions 1.0 and 1.1.  After December 31, 2019, FinLocker will only support TLS versions 1.2 and higher.

 

What is TLS?

Transport Layer Security, TLS is a cryptographic protocol that provides end-to-end communications security over networks and is widely used for internet communications and online transactions.

 

What Actions are Required?

The major browser developers (Google, Microsoft, Mozilla, Apple) already support TLS version 1.2.  If you are using an up to date browser, no action should be required.

 

How do I update my Browser?

Here is a website that covers all common Browsers that people use below;

https://www.whatismybrowser.com/guides/how-to-update-your-browser/